100s Timeout on hops

@AndyPayne @stevebaer
Is there still a limit to the timeout?
I have set the timeout to be about 500 secs and it still throws an error when I run a large study and it takes approximately 240 secs to run the definition.

When I change the parameters to make it faster, it runs and is able to compute for 150secs.

The HOPS component shows 2.5 mins ( 150 secs), whereas the rhino compute window shows 55 secs. I am not sure if i understand the Timeout :sweat_smile:

Can someone explain why the 2 different timings here?


Is the maximum allowed limit 200 secs with 0.15.1?


Hi Anuj. There are two TIMEOUT values to be aware of. One is a HTTP timeout for the server (ie. rhino.compute) and the other is a HTTP timeout for the client (ie. Hops). The timeout dialog which is exposed in the Hops preferences sets the HTTP timeout value for the client. The server timeout is set via an environment variable on the machine where the server is running. To set this one, you have to set the value of the RHINO_COMPUTE_TIMEOUT environment variable. Does this help?

Hi @AndyPayne
Thanks for the quick reply.
It makes sense.

I tested it and it works perfectly. Thanks once again.

1 Like