1-2 seconds delay for command tooltips — MMB default popup palette

It lags / right click not reactive until 1 sec delay

Still behaving to slow (1-2 seconds delay) for tooltip popup with command mapping for mouse keys in MMB default pop-up palette.

Similarly applies for right-click context menu e.g. for Auto Plane - does open on the 2nd right click only for some strange reason.

Thank you!


ditto, Reset.

Settings would work in V7
So you mean while migrating via the settings-Scheme__Default.xml to V8 settings are not working properly anymore?

Thank you!

Yes, in my case it was.

You have to also delete the xmls otherwise my problems persisted.

Thank you Inju. I am now starting to apply settings.


I didn’t delete it, it works. The Reset command in WIP deletes everything itself.

Did not for me had to delete the xml since then everything works like a charm

This problem remains even with clean settings — the popup would only show up only at the second click


I don’t have that problem!

Does occur in V8 after clean install and forced to make another ToolbarReset anyway thereafter.

The double or triple click unresponsiveness of right-click does occur on my end after installing my 250+ Aliases list which is this: Aliases 2023-03-15.txt (6.4 KB)

The problems occur not right after importing, but after closing and starting Rhino 8

No problems in V7

Strange, I need the aliases


What are you doing differently? Tried everything. Clean install. Restore Defaults. deleted all xml.

Did a clean manual unistall and reinstallation but the double-click problem persists.

here is the clean manual uninstall procedure:

I cannot replicate this behavior, pls provide SystemInfo.

@Gijs sure. Thanks so much for helping me and getting into this. Would love to work with WIP

Rhino 8 SR0 2023-3-21 (Rhino WIP, 8.0.23080.12305, Git hash:master @ e59b3ec7f9362de0c9590ae663f7e4b9756bf6e0)
License type: Commercial, build 2023-03-21
License details: Cloud Zoo
Expires on: 2023-05-05

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 3-16-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 531.41
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino
C:\Users\hanne\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\KeyShot12RhinoPlugin (78243fe3-17a0-4865-b713-88b4c224c48c)\\KeyShot2023RhinoPlugin\Rhino 7\KeyShot2023RhinoPlugin.rhp “KeyShot12RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.23080.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”

To rule out possible causes, can you try these two options:

  • disable third party plugins (keyshot in this case)
  • run Rhino in safe mode

does the problem persists in both cases?

1 Like

@Gijs thank you for your help!

Simple things are freezing for 30seconds or make Rhino freeze forever and require a full system restart with Bitlocker Recovery code demand.

Did a SafeMode with and without Keyshot plugin as I do not believe that this is an issue as Keyshot is used by many users, who won’t replicate the same issues as I believe.
With or without Keyshot plugin I experience no issues anymore in SafeMode.

Even it looks a bit messed up with two UI colors.

Is there any solution to keep settings from SafeMode as I reinstalled and deleted all registry entries and settings several times.

Thank you

Instead of reinstalling, have you also tried to repair Rhino instead? If not, try that first. Safe mode is just a diagnostic mode.